nix-config/pkgs/yuzu/default.nix
2025-01-07 23:28:53 +01:00

26 lines
673 B
Nix

{ appimageTools
, fetchurl
,
}:
let
pname = "yuzu";
version = "4176";
src = fetchurl {
url = "https://files.huwe.mooo.com/yuzu.AppImage";
hash = "sha256-bUTVL8br2POy5HB1FszlNQNChdRWcwIlG6/RCceXIlg=";
};
appimageContents = appimageTools.extract {
inherit pname version src;
};
in
appimageTools.wrapType2 {
inherit pname version src;
extraInstallCommands = ''
install -m 444 -D ${appimageContents}/org.yuzu_emu.yuzu.desktop $out/share/applications/yuzu.desktop
install -m 444 -D ${appimageContents}/usr/share/icons/hicolor/scalable/apps/org.yuzu_emu.yuzu.svg \
$out/share/icons/hicolor/scalable/apps/org.yuzu_emu.yuzu.svg
'';
}